Colt Forum banner
1 - 2 of 3 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, I am new to this site, and as of December, a new to Colt. 2 weeks ago I purchased a used 2011 Rail Gun, with an approx round count of 35. Original owner says it funtioned flawlessly. However I am finding the slide not locking back upon empty. It seems to me something that should be minor to fix and I wanted to dig around before taking it to a gunsmith. I also do not want to send it to Colt, I hear awful things about their customer service, and do not with to part with my pistol for weeks. The issue seems that the slide stop gets hung up on the tightness between it and the plunger. I've ruled it out of being a magazine follower issue. I tried varius magazines that function flawlessly in other 1911s made by both Colt and Sig. With the slide off, and the safety on, the tension between the safety lock plunger, the plunger spring, and the slide stop plunger is light enough that the slide stop functions properly. WIth the safety off, the tension is too great on the slide stop. I've been told various fixes from it being a break in issue, put 500 rounds through it and see, to polish the edge of the slide stop, to break in the plunger spring. Any suggestions would be helpful. I plan on taking it to a gunsmith this weekend if I am unable to resolve it myself.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Just now seeing this reply. Thank you. I lubed it very well, when taken apart the plunger does move freely. Malfunction happens in both dry-cycling and when shooting. Taking it out on range is how I discovered the malfunction. Oops. I already have it at the gunsmith now. I intended on getting trigger job at some point, this issue kinda just hurried that along.
 
1 - 2 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top