Colt Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Woodsman slide won\'t lock

My 3rd series Woodsman slide will not lock open after the last shot unless I am using CCI Standard Velocity. When I use high velocity [multiple brands] it fails to lock open. I have judiciously cleaned the pistol and both magazines, talked to it nicely and made offerings to the gods. No change. I know the simple solution is to shoot only CCI Standard but I would like to shoot the cheaper stuff and have proper function. Any ideas as to cause and fix? Thanks.
 

·
Registered
Joined
·
24 Posts
Re: Woodsman slide won\'t lock

I think the recoil spring may be too old and weak. Other than that I have not a clue unless the stop is just plain worn down which I imagine you would have already noticed.
 

·
Registered
Joined
·
150 Posts
Re: Woodsman slide won\'t lock

mxl-Does it lock open when-with an empty chamber and magazine with the mag. inserted-you work it by hand? If so, the problem could be the recoil spring, but it's odd that a third model would have fired enough rounds to weaken the spring. If you can find one, you probably should try another magazine than those you're using.
 

·
Registered
Joined
·
7 Posts
Re: Woodsman slide won\'t lock

I have fired five Woodsman Match Targets (three Series II and two Series III) and none of them would lock back the slide when empty. On a Series II I replaced the recoil spring and the firing pin spring (from Wolfe) and that corrected the problem. On the Series III I noticed that the slide lock spring was missing (ordered one from Gun Parts) so I replaced it in addition to the recoil and firing pin springs. After cleaning both pistols work OK now using CCI Standard Velocity ammo.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Re: Woodsman slide won\'t lock

Thanks to all for your replys.

ASA--yes, the slide stays open when operated manually.
 

·
Registered
Joined
·
150 Posts
Re: Woodsman slide won\'t lock

mxl-The fact that it stays open when operated manually would seem to indicate a weak recoil spring. I'm not sure, however, of the physics of hi-vel (not working) vs. standard vel.(works fine). I have three 2nd series sport and target and all work fine. I've also had several 3rd series models and never had a problem, so my personal experience isn't helpful. You might want to try the solutions suggested by Jeffg. -Asa
 
1 - 6 of 6 Posts
Top